I'm getting code P0715 - NewBeetle.org Forums
NewBeetle.org Forums
Go Back   NewBeetle.org Home > NewBeetle.org Forums > Discussion - Technical > 1.8 Liter Turbo

1.8 Liter Turbo Discussion area for the 1.8 liter turbocharged engine.

NewBeetle.org is the premier Volkswagen Beetle Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 06-19-2012, 02:21 PM
New Member
 
Join Date: Feb 2012
Default I'm getting code P0715

I have an 03 1.8l turbo, had it about 4 months. I'm getting only this code and it puts the transmission in a limp mode until I clear the codes. I just changed the trans fluid. It takes it a couple days for the code to come back up. 107k miles...Can anyone give me some insight as to where to start?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2 (permalink)  
Old 06-19-2012, 06:18 PM
D2Beetle's Avatar
NB Yellow Trifecta
 
Join Date: Jul 2006
Location:
Springfield, TN, USA
Car: Yellow '98 GLS / Lemon Yellow '99 GLS / Reflex Yellow & Sliver '00 GLX Turbo's
Default

Off the top of my head, check your Speed Sensor. I do not know its location on the automatic transmission; however this pic shows you where it is on a five speed transmission.
__________________
My NB Family...
Reply With Quote Quick reply to this message
  #3 (permalink)  
Old 06-26-2012, 04:56 PM
New Member
 
Join Date: Feb 2012
Default

I checked the plug for the speed sensor and it was kind of jacked up. I'm confident that its making a good connection.

It will shift fine thru all gears except from 2nd to 3rd. It kind of hesitates for just very short time, and kicks in and goes. Does not slip in any gear..Would this cause my code? Would it be the valve body doing it?
Reply With Quote Quick reply to this message
  #4 (permalink)  
Old 06-29-2012, 01:06 AM
New Member
 
Join Date: Jun 2012
Location:
Las Vegas, NV, USA
Car: 2002 Beetle 1.8 Turbo
Default P0715

my 02 vw beetle is showing codes P0715 and P0722. It appears to be in limp mode. It wont pass smog because the check engine light is on. I know these codes are for tranny speed sensors. Most of the forums say to change out these sensors. My question is: what do i do to fix the actual problem? Speed sensor replacement seems like a "band aid" to the real problem. thanks
Reply With Quote Quick reply to this message
  #5 (permalink)  
Old 08-15-2012, 02:40 AM
New Member
 
Join Date: Aug 2012
Default speed sensor,p0715 and location on 2001 vw bettle

i had the same problem.p0715 code. the speed sensor tells the transmission when to shift so if you have a bad one or the top where the wires are that connect into the senor are mess up then you get the code. I had the speed sensor(by a backyard mechanie) but was still having the problem,finally figured out that the wiring harness was broke.fixed that and the next time i turned my car on the check engine light went off. Just and FYI the speed sensor in a 2.0 2001 vw bettle is pretty much under the air filter housing.not the near the oil filter like i have read.if you take off the air filter housing its easy to get to.Your are going to need a hex bit and some extensions to get to it.the Hayes repair manuel isnt very clear about where it is.when you look at their picutre it showes near the air pump but its not.after the check engin light goes off the car goes back to shifting properly.Hope this helps.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the NewBeetle.org Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Key code and radio code question pjoz98 Questions, Issues, Concerns, or Problems with the New Beetle 3 01-14-2012 11:09 AM
P0715 sensor changed charmingtrouble 2.0 Liter Gas 1 08-07-2011 04:48 PM
p-code? pepino68 1.8 Liter Turbo 6 10-03-2010 12:18 AM
turbo intake code abe, engine code aeg huck731 2.0 Liter Gas 8 11-03-2009 11:43 PM

All times are GMT. The time now is 09:14 PM.



Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2