NewBeetle.org Forums
Go Back   NewBeetle.org Home > NewBeetle.org Forums > 1998-2011 New Beetle > 2.0 Liter Gas

2.0 Liter Gas Discussion area for the venerable 2.0 liter 4-cylinder engine.

Reply
 
Thread Tools Display Modes
  #1  
Old 06-08-2011, 05:42 AM
giink's Avatar
giinkRegistered Member giink is offline
Member
 
Join Date: Sep 2009
Location:
Pelham, NH, USA
Car: 2000 VW Beetle 2.0L (AEG)
Default * PO422-Main Catalyst Efficiency Below Threshold Bank1

Got the Check Engine Light on once again... here's the deal, got the PO422 code triggered. I've got a brand new Bosch MAF Sensor, Bosch Upstream & Downstream O2 Sensors (2yrs. old), New Catalytic Converter (5 yrs. old). Checked for exhaust leaks, visual inspection of converter, no holes or rattles and the exhaust manifold looks good as well. Average mileage per year around 6K. Only 21K since brand new converter.

Any other ideas on what might be causing the light to be on??????????????

Help
Reply With Quote
  #2  
Old 06-08-2011, 12:43 PM
JP's Avatar
JPRegistered Member JP is offline
Senior Member
 
Join Date: Nov 2010
Location:
Cortlandt Manor, NY, USA
Car: 2001 VW Beetle GL 2.slow
Default

you may have a clogged cat again, or the o2 sensors may be dirty from bad fuel or running too rich, have you added any additives to your fuel lately could be that as well, (octane booster etc.)
Reply With Quote
  #3  
Old 06-08-2011, 03:45 PM
giink's Avatar
giinkRegistered Member giink is offline
Member
 
Join Date: Sep 2009
Location:
Pelham, NH, USA
Car: 2000 VW Beetle 2.0L (AEG)
Default

Hi, no additives to fuel of any kind added. Have been using only Shell regular gasoline because of it's cleaning agents. I just can't believe it's the Cat or the Sensors.


Really frustrating
Reply With Quote
  #4  
Old 06-11-2011, 08:15 PM
gamefoo21Registered Member gamefoo21 is offline
Member
 
Join Date: Jun 2009
Location:
Regina, SK, Canada
Car: Yellow '98 Beetle AEG + 01M
Default

New is not 5 years old... That's mid life... The mileage is relatively low though.

What brand of Converter?

What kind of oil are you running? Does it burn any oil?
Reply With Quote
  #5  
Old 06-13-2011, 12:01 AM
giink's Avatar
giinkRegistered Member giink is offline
Member
 
Join Date: Sep 2009
Location:
Pelham, NH, USA
Car: 2000 VW Beetle 2.0L (AEG)
Default

Not sure... it was an after market converter that was installed by Midas. Never burns any oil and I use a Pennzoil 10w-30w
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Catalytic converter below efficiency threshold jeffro0001 2.0 Liter Gas 10 02-09-2010 11:21 PM
P0133, PO322, PO422 and P1176 Bella1998 2.0 Liter Gas 0 06-15-2009 02:05 PM
Codes: P0133, PO322, PO422 and P1176 Bella1998 2.0 Liter Gas 3 06-01-2009 03:07 PM
LF/WTB dual downpipe with catalyst maximus_d Market Place Archives 0 09-18-2008 12:20 PM
MPG & fuel efficiency question callisto9 2.0 Liter Gas 9 10-05-2005 09:47 PM

All times are GMT. The time now is 01:42 PM.



Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2016, vBulletin Solutions, Inc.