Go Back Home > Forums > 1998-2011 New Beetle > 2.0 Liter Gas

2.0 Liter Gas Discussion area for the venerable 2.0 liter 4-cylinder engine.

Thread Tools Display Modes
Old 04-16-2012, 08:55 PM
Little Yellow BugRegistered Member Little Yellow Bug is offline
New Member
Join Date: Apr 2012
Default Sensors/Codes/Lights Headache

Hi guys!!

I started my new thread here:

but right now I'm focused on the following problems I want to fix. The check engine light is on w/ these codes:

Mass or Volume Air Flow A Circuit High Input

Injector Circuit / Open - Cylinder

o2 Sensor Heater Bank 1 Sensor 1

2 days prior to the engine light coming back on, I had it on and cleaned the sensor w/ MAF cleaner from advance auto parts and replaced the air filter. Yesterday, the light came back on. While I was checking the hood, I noticed there's a hose/tube right below the MAF sensor that came off, and needs a clamp or something to be tight... could that be causing any of this?

Thanks in advance, any input is much appreciated!!
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Homelink=headache! kelleygraves2 Questions, Issues, Concerns, or Problems with the New Beetle 6 06-21-2011 10:51 AM
Headlight Headache... sntaylor2005 Technical Modifications 12 02-15-2011 08:43 PM
P 1198 headache Limitwheel 1.8 Liter Turbo 1 07-24-2010 08:07 PM
help! itercooler headache eliramos525 1.8 Liter Turbo 3 02-06-2010 09:30 PM
a/c problem, headache ???? mickstir 2.0 Liter Gas 0 06-28-2008 07:03 AM

All times are GMT. The time now is 06:24 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2016, vBulletin Solutions, Inc.